FL Studio - pops / clicks at the beginning of the loop when using Rift on an instrument

Hey, my English is not so well, so I hope you can understand my problem. Ask if anything is unclear please.

I use the newest version of Rift & FL studio. I have an instrument with Rift on it. I add a 1 bar long note and add some curve modulation. When I play it back in the playlist there is a click / pop at the beginning of the song. When I duplicate that pattern, the following patterns do not have that pop / click and loop just fine without any noise. Only when it loops back to the beginning of the song again, it pops.

When I loop the pattern in the step sequencer, it pops every time the loop starts from the beginning.

Without pressing play I can play the instrument and hold the note with my midi keyboard and it loops without any clicks at the beginning of the looped modulation sequence.

I tried disabling/enabling “Reset Plugins on Transport”.

Can anyone help me? I had the same issue when trying out DM Infiltrator in FL Studio.
I asked in the Image Line forum too already, but thought maybe here you have experiences with the problem too, and can help to solve the problem.

Greetings :slight_smile:

Hey! Sorry you’re experiencing that — so you’re saying the pop is definitely coming from rift? Do you know if it’s the filter or feedback or which part of the engine by chance?

If it’s possible for you to send us your preset which is exhibiting the behavior we can take a deeper look at it.

a preset where it happens for example is “Bitter Tides” and I know this is not a problem about having a short attack time at the beginning that can introduce a click, that is common with envelope shapes. This can’t be, because the click happens only when the loop restarts from song begin in the arrangement mode.

For now I only know that I had the same problem with demoing Infiltrator.

At the moment I can’t properly reproduce and take notes to show the problem.
But in the end of this month I ll have more time and add a screen recording where I can show you exactly what I mean.

See you then and thanks for the help!


Alright, So here the desktop recording.

The click only appears when the loop starts from a song beginning and only when Rift is on. It has nothing to do with the curve envelope, as you can see and hear.

I suppose it’s more a FL Studio problem, which is why I start a support request in the Image Line forum too. But maybe someone here has an idea too.


I tried it with my Onboard Realtek soundcard and with my Focusrite Scarlett Solo, both with different Audio Output Sources (asio4all, focusrite asio usb, realtek) and also different buffer settings - it happens in all cases, so it should not have something to do with the soundcard.

another video where it shows the behaviour with empty space before and after the loop:

first two variations - no noise
3rd variation - noise when loop jumps to song/loop beginning.

Hey @ancient7 thanks for posting this. I was able to reproduce and fix the issue. It’s going to take a us a month or so to get an update out since there are some other things getting worked on — but this fix will be in there!


1 Like

That’s great to hear. Looking forward to the update.

Thanks for the support!

@ben.minimal Hey, any news on when the update will come?

Hi @ancient7, apologies about the delay. We’ve been updating / fixing a number of other things in Rift. I believe we’ll have updates out for all of our products in August. Thanks for your patience!

1 Like

Hi @ancient7 I just updated the installers for all of our plugins, which includes this fix. You can download them here: http://minimal.audio/account/products

Please let me know if you run into any issues!

1 Like

Problem is gone, thanks alot! :heart: