I have to sign-in to Rift literally every time I use it

Hello. I am having a frustrating issue with Rift that has made it borderline unusable for me.

I have to log-in to Rift literally every time I open a DAW session. If I save a project with Rift instances, and return to it a later date, I again have to log in. If I close my DAW, and reopen it later that day, and start a new project with a new rift instance - AGAIN I have to log-in. The only time it actually seems to save my log in information is when I am in a single session of a single project - I I can keep adding rift instances to the same project once I have logged in once. But as soon as I close my project or DAW - I have to do it all again. Occasionally it will even say I do not have any additional seats available, despite consistently using this VST on only a single computer… when i check my logged-in sessions on your website it confirms that the current seats are both occupied by the exact same computer I am using currently… which is odd?

No other music plugin I use is like this. Surely this cannot be by design? It is made extra frustrating by the fact the plugin does not save previously entered passwords or usernames, nor does it allow changing focus from the username field to the password field using the TAB key. Forcing me to retype this same information every time, clicking each little field to type in the required information, has become a huge impediment to my creative workflow to the extent that I have completely stopped using the plugin - it really ruins my flow. This is unfortunate because I like the plugin, and I paid for it, so I thought I’d ask on here how I can stop this.

Is this a bug? Is something on my system misconfigured? Help!

1 Like

Hey @vegenaut, I’m sorry to hear about this — sounds really frustrating. There is an issue with our licensing system that was introduced in our last update. We’re working on fixing it but in the mean time, you can download the previous installer, which shouldn’t have this issue. You’ll likely have to release your seats online one more time, though.

If you run into anything else please let me know or reach out to out support at hello@minimal.audio.

EDIT: I removed the link to our previous installer since this should be fixed and you can download the most up to date installer from your user account here: https://www.minimal.audio/account/products

1 Like

easy enough! that seems to have done the trick. Thanks so much for the response and I’ll keep an eye out for updates in the future

@ben.minimal are you referring to the Mac Installer(2.0.2r2) that is still up on the website? I’ve been having the same issue, I used that version – now I have to login every time and I have lost all my packs + presets— I also had to clear a seat in order to use the plugin— I followed the instructions to do a manual uninstall and I’ve tried this 3x now with the older versions you posted here in the gdrive— none of them work-- I’m still having to login over and over and I’ve lost my packs … I’m kinda frustrated at how much time i’ve wasted here, it appears something is wrong with my license as you have stated but the frustrating manual uninstall is not enough to clear it. Do you have a way to get this working again? I need the packs too.


Hey @humanbeingbeing sorry to hear you’ve been having trouble with Rift. Definitely sounds frustrating and we want to resolve this asap.

I believe the users we’ve talked to so far have been having this login issue on Windows and we have a fix for that that will be coming out this week. It sounds like you’re on Mac, though?

It would be really helpful if you wrote into our support at hello@minimal.audio, copied this post, shared your minimal.audio account email, and let them know what OS you’re using . I just shared this post with them to give them a heads up.

By “packs” I’m assuming you’re talking about preset packs? If you deleted any user presets hopefully you haven’t emptied your trash and you can still grab them from there after we get this working. Any factory or expansion presets will be reinstalled with the product’s installer.

Thanks for your patience!

hi @ben.minimal yeah so I did actually reach out via the contact us form on the minimal site and I got a response back from Griffin so I presume your support squad is tracking the same issue-- I am talking about mac but I observed my other seat (which is windows) suddenly is also asking me to login back in, I haven’t gone further… for ‘packs’ yes presets, I didn’t delete anything initially they seem to have disappeared on the their own… reinstalling any of the 3 versions failed to reinstall the presets, I presume they must be linked to the license somehow… but yeah I seem to be seeing issues on windows and mac, so perhaps its not ventura related after all… I can’t use Rift right now and it is affecting my projects so I’m keen to hear any updates.

Thanks @humanbeingbeing

I think I see your support thread now and it looks like you’re on Ventura? The new installer that we’ll be releasing this week fully supports the new macOS but the current one unfortunately does not. I believe our update fixes some permissions issues that would explain what’s going on for you. I’ll let you know when the installers are available.

@jake.minimal has been working on the update. Maybe he has something to add.

Talk soon

Hey! Yeah so sorry this happened for you – we got hit with a double whammy with Windows OS Update and then shortly the new Mac OS Ventura.

The release this week should fix ALL license issues for both OS’s – we’ve also been working with JUCE and a group other small audio plugins also struggling with similar issue.

If you can hold tight for just a few more days we’ll have it all sorted out! Thanks so much for your support and patience in the meantime we understand this totally sucks!

Same issue here with MacOS 13 Ventura, looking forward for the update.

@vegenaut @neonvoid @humanbeingbeing

I just updated the installers for all of our plugins on our website. This update fully supports Ventura and fixes the issue with Rift asking you to log in every session on Windows!

You can grab the installers here: minimal.audio/account/products

Thanks for your patience, and let me know if you run into any issues!

thanks @ben.minimal I have just tested with ventura and my windows machine, both working now and the presets have returned— I should mention i did have to end the session of the mac seat as the plugin stated it was in use, no big deal. Windows seat was fine. Thanks.

Hey Minimal team, I am experiencing this same issue after updating to Ventura 13.0.1 this week. I was using the newest version per your website but even after uninstalling and reinstalling Rift, I am still experiencing this issue. Submitted a support ticket yesterday but haven’t received a confirmation email yet so just wanted to follow up here

Thanks for any suggestions!

Hey Matty! Apologies it took a bit for me to see this through the holidays – I’m assuming however that the support team got back to you and got this solved?

Yep, all good. Thanks, Jake! Happy New Year.

1 Like

This has been a big issue for me as well. I had to refund 2 clients so far because I could no longer access content in my pro tools session where rift was used.

Hey – did you ever get in contact with support and get this resolved?

To anyone experiencing this issue I’ve created a blog post to solve it: Support Solutions: "No Seats Available"

This will solve the issue if you’re prompted to log into the plugin every time you open the UI as well.
Hope this helps!


I have the same Problem. But now you eat up all your sets, when you try to activate.grrr

And it is 8 month later.

Hey! So we finally found why this was happening for some windows users and it was a folder permissions issue which took us forever to track down. We’ll be shipping an official patch for it soon but in the meantime we have an updated installer we can send.

The long story though is it can also be resolved by going to your minimal folder in program data and modifying the permissions to allow writes for your user.

I was installing everything on my system after a clean Windows install, I figured that modifying permission might not be enough, as I had to delete the minimal.license file before registering in order to make Rift stop asking my info every time. Just throwing the info out here in case someone else still has the same issue on Windows.