Morph EQ Log In Issues

Hi, I’m having issues with Morph EQ where I have to login to the plug in every time I reopen my DAW. I’m using a Windows PC and I followed the relevant instructions for downloading the latest installer and also updating the read/write security settings on the Minimal Folder and sub folders, but the problem persists. It’s very frustrating, any help to resolve would be much appreciated.

Hey, sorry you’re experiencing this and thanks for trying all the recommended steps already.

If you’re able to login to the plug-in, it’s still most likely that it is a permission issue making the plug-in unable to save the license file to disk so it’s fully unlocked.

If you’re on windows I believe you have the ability to right click and open your project as administrator — we’ve seen this sometimes solve the issue. Could you give that a shot? Once you get the license to save correctly you shouldn’t need to do it again.

Also when developing Currents installers we reviewed all of these permissions settings and improve the installers, we’ll be shipping patches to everything in the coming weeks as we add the RTO plan — we’ll get it sorted!

Hi Jake, thanks for your quick response! :slight_smile:

If I run the DAW as admin, morph eq works as it should, I didn’t have to log in at all. However, when I go back and reopen the DAW as usual, the plug in still requires log in every time.

I also tried opening as admin and logging out of the plug in and then logging back in and saving, thinking that might write the licence to the correct location but it didn’t work.

So it seems at the moment, the only way is to run the DAW as admin.

I’m ok with that for now but would prefer a fix. Happy to try out other ideas/updates for you if I can help.

Ahh bummer that’s so weird, usually the plug-in has trouble saving the files, it sounds like in this strange case it may actually be having trouble reading the file…

We will need to chat about it internally I think a little bit — just so we have all the info can you let me know the win version you’re on and the DAW?


Hi Jake, think I’ve figured it out! The instructions said go to the Program Files directory and update the security settings under the Minimal folder. But when I drilled down there are no files stored there or the Morph EQ folder! The licence file actually gets stored under C:*ProgramData*\Minimal\Morph EQ, not C:\Program Files\Minimal\Morph EQ. So I updated the Users security settings to allow write access for the Morph EQ folder under Program Data and it seems to be working now (early days so will keep testing :slight_smile: As an aside, I’m on Windows 11 and using Reaper. Cheers!

1 Like

That would do it!!! I will talk to our support team and make sure that gets updated on Monday thanks so much for notifying me of that and checking once more!

No problemo! Glad I could help. :slight_smile: